今天看啥
热点:

Java问题解决:使用maven install 和 package时出错,mavenpackage


今天在idea中使用maven install 和 package时出现以下问题:

[WARNING] The POM for org.apache.maven.plugins:maven-compiler-plugin:jar:3.1 is missing, no dependency information available
[WARNING] Error injecting: org.apache.maven.plugin.compiler.CompilerMojo
java.lang.NoClassDefFoundError: org/codehaus/plexus/compiler/util/scan/mapping/SuffixMapping
[WARNING] The POM for org.apache.maven.plugins:maven-resources-plugin:jar:2.6 is missing, no dependency information available
[WARNING] Error injecting: org.apache.maven.plugin.resources.ResourcesMojo
java.lang.NoClassDefFoundError: org/apache/maven/shared/filtering/MavenFilteringException

问题出现的第一时间呢先问了下小伙伴有没有这种情况,遗憾的是并没有,所以只能自己解决了。

看提示信息是丢失maven-compiler-plugin jar 和 maven-resources-plugin jar,所以就想是不是加上这两jar包就可以,在我不确定的情况百度出场了

www.bkjia.comtruehttp://www.bkjia.com/Javabc/1316468.htmlTechArticleJava问题解决:使用maven install 和 package时出错,mavenpackage 今天在idea中使用maven install 和 package时出现以下问题: [WARNING] The POM for org.apache....

相关文章

    暂无相关文章
相关搜索:

帮客评论

视觉看点